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DigitalMicrograph 软件入门 
 

在电子显微学界 Gatan DigitalMicrograph (DM)是一个为人皆知的软件。DM 具有采集

图像，图像处理和分析，数据管理和报告打印等多种功能。为了使广大用户能够更好

地熟悉和掌握 DM 的多种功能，我们特别编辑了这本练习册。由于 DM 软件的功能五

花八门，丰富多彩，我们不可能对它的每一项功能作详细的介绍。本练习册汇集了一

些代表性很强的练习。每一个练习都有详细的步骤说明。希望以此能够将读者带进

门，以便日后自学提高对 DM 软件的理解和操作使用能力。从而更好地满足用户在数

字电子显微学方面的需求。  

 

数字暗室 
同传统的底片技术相比，数字图像最突出的优点在于图像可以很容易地通过计算机软

件进行多种操作与变换。很多同暗室相关的实验步骤都可以通过软件在计算机中很容

易地实现。比如，调节图像的亮度或衬度，选区放大，图像的非均匀亮度调节（遮挡

曝光），图像粘贴，贴字和测量等。上面所举的例子构成了数字暗室的基础。 

数字暗室图像技术可以大大地提高工作效率。通过使用计算机软件，很多繁琐，重复

性高和费力的工作步骤可以被大大地简化。这一点仅从获取一张洗印好的图片所需经

过的全过程就可以清楚地说明（底片冲洗，暗室放大，贴字等）。 
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DigitalMicrograph 工作环境全貌 

 

 

 

(DM Menu)菜单：多种操作指令按照其功能分类。 

(DM Tool) 工具; 这些可移动窗口包括标准工具以及多种与被显示图像有关的信息。 

(Image) 图像： 图像在 DM 软件里被显示的位置。 

(Results) 结果： 这个文字窗口包含 DM 软件在运行中的一些输出信息。比如图像分

析和测量的结果。窗口里面的文字可以被拷贝或以文件格式存储。 
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练习一 

 
1． 图像的亮度与衬度 

图像亮度与衬度的调节是保证图像质量的重要一环。DM 可以很容易地对图像的亮度

和衬度进行调节。为了更好地说明 DM 调节亮度和衬度的原理，我们首先讲解一下计

算机屏幕显示的原理。一般来讲，屏幕显示器的灰度为 8 位（黑白）24 位（彩色）。

Gatan 数码相机最低是 12 位（最高 16 位）。一个 12 位的数字图像含有 4096 个强度

值。屏幕显示器的灰度分辨率为 256（8 位）。因为图像的强度分辨率大于显示器的灰

度级别，所以我们必须首先确定怎样使用有限的显示器灰度来显示图像中更高数目的

强度。换句话说，我们可以在图像中任选两个强度值，指定较低的强度为屏幕显示器

的黑色（灰度= 0），较高的强度为屏幕显示器的白色（灰度= 255）。由此我们定义

了一个图像（4096 个强度值）与显示器（256 灰度）之间的相互关系。 

图像亮度与衬度的调节实际上就是改变上述图像与显示器的相互关系。 

操作步骤： 

在计算机桌面的文件夹(Gatan School)里，打开（单击）图像”Nerve.5.dm3”. 

DigitalMicrograph 软件启动并显示图像。 

这是一个衬度较低的图像。图像中的铜网像（黑）大大地影响了样品真实图像的显

示。请按照以下的步骤说明来调节图像的亮度和衬度。 

－ 在显示窗口中，使用亮度和衬度划尺来优化图像的显示。 

 

－ 双击”Contrast”或”Brightness”可以复原亮度或衬度的初值。(请练习并学会使用)。 
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－ 强度直方图”Histogram”窗口（如下），用鼠标选择位于右边的强度峰（点击峰的

左端，按下鼠标并拖至峰的右端）。这个操作改变了上面提到的图像与显示器之间的

相互关系。从而改变了图像的显示。 

   双击此处 

－ 双击直方图窗口下端的灰度横带可以复原直方图的初始显示值。(请练习并学会使

用)。 

－ 使用在显示窗口中的”gamma”划尺也可以改变图像的显示。双击”Gamma” 可以复

原其初始值。(请练习并学会使用)。 

强度直方图窗口中的曲线称为“衬度变换曲线”（它就是我们上面提到的图像与显示

器之间的强度对应关系）。在线性模式里，它是一条直线。在”gamma”显示模式中，

它变为非线性关系。此外通过选择 Image Display…(在 Object 菜单下)，也可以把线性

模式变为非线性。 

具体步骤如下： 
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在图像显示的对话窗口中(上右图)，用鼠标点击衬度(Contrast)。然后在其右面的模式

(Mode)选择项中，选取均匀化(Equalized)。最后点击 OK 退出。用划尺调节亮度或衬

度，并观察图像的变化。此时强度直方图中的曲线已经不再是直线了。 

现在我们再回到原先的线性模式(Image Display…, 选择 Linear mode). 在考察(survey)设
定选择中，练习选择 cross-wire。用鼠标选择自动考察(AutoSurvey)。然后用鼠标点击

存储键(Save Defaults)。点击 OK。观察图像的变化。  
重复练习 sparse, whole image, 和 reduction，观察图像的变化。 

 
下表列出了显示图像变化的原因。 

图像：Nerve.5.dm3.    最大值 = 2595，最小值 = -2。 

 

上面的表格列出了不同的考察(survey)设定选择对图像显示所依据的最大和最小值的影

响。从中不难看出为什麽显示图像会因考察方式而变化。 

 

2． 彩色显示（伪色） 

一般来说，电子显微镜图像应该用黑白模式显示。但有的时候有必要用伪彩来特别突

出图像中的某些细节，或者增加一些显示的特殊效果。在用伪彩显示时，屏幕显示器

的 256 个灰度（8 数位）同一个彩色配置表建立一一对应关系，从而将一幅黑白图像

转换成彩色图像。 

操作步骤： 

在计算机桌面的文件夹(Gatan School)里，打开（单击）图像”Lathe turnings at 
16x.dm3”. 

在 Object 菜单下，选择 Image Display… 

在左面直框内（下图）Display 下，选择彩色(Color)。在彩色配置表(Color Table)下，

选择彩虹(Rainbow)，点击 OK 退出。此时图像在伪彩模式下显示。下图中的彩色方块

矩阵就是上面所说的黑白-彩色配置表。 

用亮度或衬度划尺来改变图像的显示效果。 

M in  (黑 ) M a x  (白 )
C ro s s -w ire 2 1 .0 2 1 0 3 .0
S p a rs e 1 9 .0 2 4 0 6 .0
W h o le  im a g e -2 .0 2 5 9 5 .0
R e d u c t io n 2 1 .0 2 3 8 8 .8
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再回到图像显示(Image Display…). 选择彩色(Color)。在彩色配置表(Color Table)下，选

择温度(Temperature)，点击 OK 退出。注意现在的彩色方块矩阵（黑白-彩色配置表）

已经变了。点击 OK 退出。复原亮度和衬度值。 

自定义’黑白-彩色配置表’ 
回到图像显示(Image Display…). 选择彩色(Color)。在彩色配置表(Color Table)下，选择

温度(Temperature) 或彩虹(Rainbow)。 
 
在彩色方块矩阵中，左上角的彩块代表图像中最低的强度值。强度由左向右递增。右

下角的彩块代表图像中最高的强度值。 
 
用鼠标点击选择整个(或部分)彩色方块矩阵。选择后，出现一个对话窗口（见下

图）。此时你可以选择任意的颜色来代表图像中的最低的强度值，然后任意选择另外

一个颜色来代表最高的强度值。 
 
上面所选的两个颜色在连续彩色图表中（见下图）用两个小圆圈来表示。在两个圆圈

之间连一条线。在这条线上的所有颜色就构成了一个’黑白-彩色配置表’. 这个自定义配

置表可以很方便地被储存起来（点击 Save 健）备将来使用。 
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3． 图像注释 

图像注释通常包括在图像中加入一些文字说明， 箭头标记，和其他几何图形(例如，

长方或圆形等等)。DM 软件里有很多这方面的功能可供用户选用。图像注释使用的工

具可以在标准工具盘（Standard Tool – 通常位于 DM 软件窗口的左上角）上面找到。 

下图显示的是图像注释工具（虚线框内）。 

 

 

文字加入 

在计算机桌面的文件夹(Gatan School)里，打开任何一张图像。 

首先用鼠标点击“文字注释”图标（上图中 A 图标）。然后点击图像中的任何一点，

此时出现一条竖直短线，键入所需要的文字。再用鼠标点击图像中的一点即可终止文

字输入模式(竖直短线消失)。 

用鼠标点击刚刚输入的文字，按下并移动鼠标即可改变文字在图像中的位置。 
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改变字形 

用鼠标点击选择图像中的文字（文字块的四角变为绿色）。然后在物体（Object）菜

单下，选择字形(Text Font)。 

改变字体大小 

同上。在物体（Object）菜单下，选择字体大小(Text Size)。 

改变字体类型 

同上。在物体（Object）菜单下，选择字体类型(Text Style)。 

改变字体背景 

同上。在物体（Object）菜单下，选择字体背景(Background)。 

画线段和箭头 

用鼠标点击“线段”图标（文字图标右侧）。选择图像中的任何一点，按下并移动鼠

标即可任意在图像中画线。 释放鼠标，即终止画线模式。 

在画线时，同时按下键盘上的移动键 “Shift”，可以把直线的方向限制在 0, 45, 和 90
度。 

在画线时，如果同时按下键盘上的“Alt”键 , 可以把直线变成单箭头线。如果同时按下

键盘上的控制“Cltr”键, 直线变成双箭头线。 

试试看： 如果同时按下键盘上的”Shift” 和“Alt”，或”Shift”和“Cltr”键 , 会出现什麽结

果？ 

改变线段的类型 

首先用鼠标单击图像中的线段（此时线段的两个端点变为绿色）。在物体（Object）
菜单下，选择背景(Object -> Background)。DM 软件里一共有四种不同的背景可供选

择。 

画矩形或方形 

用鼠标点击“方形”图标。选择图像中的任何一点，按下并移动鼠标即可在图像中画

出任意的矩形。 释放鼠标，即终止模式。 

在画矩形时，如果同时按下键盘上的移动键 “Shift”，矩形变为正方形。 
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改变矩形或方形的类型 

同上，首先用鼠标单击图像中矩形的任何一个边（此时图形的四个端点变为绿色）。

在物体（Object）菜单下，选择背景(Object -> Background)。DM 软件里一共有四种不

同的背景可供选择。 

试试看： 选择填充(Filled)或不填充(Not Filled), 会出现什麽结果？ 

画椭圆形或园形 

用鼠标点击“园形”图标。选择图像中的任何一点为椭圆或圆的中心，按下并移动鼠

标即可在图像中画出任意的椭圆图形。 释放鼠标，即终止模式。 

在画椭圆时，如果同时按下键盘上的移动键 “Shift”，椭圆变为园形。 

改变椭圆的类型 

类似直线和方形，先用鼠标点击图像中的椭圆或园形（此时在图形的四周出现四个绿

色端点）。在物体（Object）菜单下，选择背景(Object -> Background)。 

试试看： 选择填充(Filled)或不填充(Not Filled), 会出现什麽结果？ 

 

4． 注释物体的规则排列 

图像中的各种注释物体（例如文字，或几何图形，例如线段，方形，园形，等等），

经常有必要将它们做有规则的排列。 在 DM 软件中可以将这些注释物体按水平中心

线，竖直中心线，或中心点排列。 

具体步骤如下： 

用鼠标选择所有的注释物体（按下鼠标画一个虚设的方形区来包围所有的注释物体，

或按下移动键“Shift”, 用鼠标点击来选择每个注释物体）。被选择后的注释物体，端

点变为绿色。 

在物体（Object）菜单下，选择排列(Object -> Align)的类型。 
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5． 注释物体合并 

如果图像中有很多的注释物体，在规则排列做完后，为了便于保持它们之间的排列关

系，最好将这些注释物体合并变成一个综合注释物体。反过来也可以把一个综合注释

物体拆成许多原始的注释物体。 

用鼠标选择所有的注释物体，在物体（Object）菜单下，选择合并(Object -> Group)。
如果要拆散的话，则选择拆散 (Object -> Ungroup)。 

 

6． 图像剪裁 

在 DM 软件中可以非常容易地把图像中的重要部分剪裁出来，并在一个新的图像窗口

中显示。 

具体步骤如下： 

在计算机桌面的文件夹(Gatan School)里，打开任何一张图像。 

使用“矩形区域选择工具” (ROI 工具块中的虚线矩形图标，见下图) 在图像中选择要

裁剪的区域 (在预选区域的左上角点击并按下鼠标。移动鼠标至区域的右下角。释放

鼠标。此时，选择的区域被一个虚线矩形框标出。 

 

同时按下键盘上的 “Ctrl” 和字母 C 键。拷贝选择区域。 

然后，同时按下键盘上的 “Ctrl”, “Alt” 和字母 V 键。在一个新的图像窗口中显示选择

区域。 

 

7． 图像显示与文件显示 

在 DM 软件里，有两种模式可以用来显示图像。第一种模式叫图像模式 (Image)，第

二种叫文件模式 (Page)。在目标 (Target) 移动窗口中 (见下图)，有两个钮扣键。实心

键显示当前的显示模式。 

在图像模式中，图像显示窗口与图像尺寸大小一样。在文件模式中，图像显示窗口则

与文件(纸张)的大小一样。在该显示模式中，我们可以清楚地看到图像在纸张上的显

示位置和打印尺寸。此外，还可以在文件中添加其它的图像。 
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练习： 

在计算机桌面的文件夹(Gatan School)里，打开任何一张图像。 

你可以看到图像是在图像显示模式里 (打开图像时的显示模式取自于该图像最后一次

被存储时的显示模式) 。用鼠标点击文件(Page)钮扣键。(如果找不到目标-Target- 移动

窗口，可以按照下面的步骤来找。Windows 菜单下， Floating windows -> Target.)。 此
时可以看到图像在文件模式中显示。用鼠标点击图像 (Image) 钮扣键，回到原先的图

像显示模式。 

文件显示模式看起来很象文字处理程序中的预展功能。它可以显示图像在纸张上的位

置和打印尺寸(下一个练习)。 

用鼠标点击图像中的任何一点(此时图像的四个顶点变为绿色)，保持鼠标按下状态，

移动鼠标可以改变图像在纸张上的位置。如果用鼠标点击四个绿色顶点的其中一个，

保持鼠标按下状态，移动鼠标可以改变图像的大小。 

在文件上添加第二张图像 

首先确认当前的图像是在文件显示模式中。在该图像中剪裁一张小区域图像(你还记得

怎样做吗?)，或使用另一张图像。 

点击刚剪裁图像的窗口(或另一张图像)。同时按下键盘上的 “Ctrl” 和字母 C 键。拷贝

图像。然后，点击第一张图像的窗口(处于文件显示模式)。同时按下键盘上的 “Ctrl” 
和字母 V 键。添加图像任务完成。用鼠标可以随意改变图像的位置。 
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此外也可以随意改变图像的显示尺寸，甚至可以随意改变图像的亮度和衬度而不影像

文件中的其它图像。当然也可以规则排列这两张图像，或者把它们合并(Group)等等。 

 

8． 图像的打印尺寸 

打印高质量的图像与拍摄高质量的图像同等重要。图像可以由 DM 软件在所连接的打

印机上直接打印。为了保证图像的打印质量，这里有必要介绍一下打印图像时的几个

要素。 

数字图像与胶片图像的最大区别在于前者不能无限制地放大。如果数字图像的放大倍

数过大，就会出现所谓的”像素化” 现象，即在打印的数字图像中可以看见一个一个的

小方块。这些小方块实际就是数字图像中的像素。为什麽放大胶片图像时不会出现”像
素化” 现象呢? 原因在于感光胶片中的感光颗粒尺寸大小不一。所以在放大时不会出现

尺寸大小完全一样的像素。 

那麽应该怎样避免”像素化” 现象的出现呢? 一般来讲，如果打印的图像每英寸具有

144 或更多的像素，”像素化” 现象就会减小到最小程度或者完全消失。这样一来，我

们可以很容易地确定一幅数字图像的最大打印尺寸。例如，一幅 1024 x 1024 的数字图

像，其最大打印尺寸大约为 1024/144 ~ 7 英寸(~18cm)。 

在图像的文件显示模式中，用鼠标点击图像中的任何一点(图像的四个顶点变为绿

色)。此时图像的打印尺寸在控制移动窗口(Control)内显示 (见下图)。字母 W 和 H 分
别代表打印图像的宽度和高度。(如果找不到控制- Control - 移动窗口，可以按照下面

的步骤来找。Windows 菜单下， Floating windows -> Control)。、 

 (打印尺寸为 7 英寸长 7 英寸宽) 

 

9． 图像显示的坐标系 

数字图像的基本单元叫做像素。图像中每一点和该点上的强度由像素坐标(x,y) 以及强

度值 I(x,y) 来表示。在 DM 软件中，如果鼠标在被显示的图像内移动时，鼠标所在的

像素位置(x,y) 以及该点的强度值 I(x,y) 可以很容易地在”图像状态” (Image Status)窗口

中读出(见下图)。 
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DM 软件可以用两种不同的坐标系来显示一幅图像，即校正坐标 (Calibrated) 和非校正

坐标 (Uncalibrated)。在校正坐标系中，坐标的显示单位通常是�m, nm 或其他的实空

间的单位。在非校正坐标系中，坐标的显示单位则是一对无量纲的整数。坐标系的原

点在图像的左上角。 

   

 校正坐标(Calibrated)  非校正坐标 (Uncalibrated) 

”目标”(Target)窗口中的标尺图标(上图)代表校正坐标。用鼠标点击标尺图标后，标尺

变成一条短线。此时图像使用非校正坐标显示。反过来，我们以也可以用鼠标从非校

正坐标变回校正坐标。 

 

10． 图像的标尺 

标尺对于电子显微图像来说至关重要。使用预先储存的电镜放大倍数校正表，DM 软
件对从 CCD 相机采集的每一幅图像进行自动校正。如果电镜的放大倍数没有被预先

校正(即不存在放大倍数校正表)，DM 软件则会对图像进行错误的校正。所以在使用

CCD 相机采集图像时，一定要先校正电镜的放大倍数。 

因为图像已经被校正，所以 DM 软件可以正确显示图像的标尺。 

一般来讲，DM 软件自动显示图像的标尺。但是如果被显示的图像没有带标尺，可以

按照下面的步骤来显示标尺。菜单 Edit -> Data bar ->Add Scale Marker.  

标尺的自动显示： 

在使用 CCD 相机采集图像时，使用下面的设定可以使每一张图像都带有标尺。 

菜单 File -> Global Info…。单击 Data Bar 并选择自动添加图标(Add Scale Marker After 
Acquisition) (见下图)。 
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11． 图像校准 

对于一张从未被校正过的图像(比如经过图像处理后的图像)来说，使用上面所说的方

法（菜单 Edit -> Data bar ->Add Scale Marker.），会产生下面的错误。 

 

 

 

我们首先要校准图像。具体步骤如下： 

- 选择线 ROI （虚线）工具。 

- 选定图像中任何已知两点。 

- 菜单 Analysis -> Calibrate….  

- 在对话栏中，首先选择适当的单位（如µm）,然后键入所选两点的间距。选择 OK 退

出。 
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上面的步骤已经完成了图像的校准。选择菜单 Edit -> Data bar ->Add Scale Marker. 

 

12． 线强度分布图 

在做图像分析时，有时会希望得到图像中强度沿某条指定直线上的分布。下图显示的

是 DM 软件的标准工具库。用鼠标点击”线分布” 图标(正旋曲线)。然后用鼠标点击图

像中的起始点(并保持鼠标的按下状态)，移动鼠标到终点并释放鼠标。图中的蓝白线

表示刚刚画过的直线。它的强度分布图在另外一个窗口中显示。 

 

如果用鼠标双击图像中的蓝白线，会出现一个对话窗口(见下图)。该窗口显示起点和

终点的坐标位置，以及线强度的积分宽度(默认值为 1)。如果键入一个大于 1 的积分宽

度值，强度分布图会自动更新。增加积分宽度有利于增加强度分布图的信噪比。 
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13． 图像的储存格式 

DM 软件支持多种标准图像储存格式。如果没有做特别设定，图像的默认储存格式为

Gatan 特殊格式（.dm3）。与其它格式不同之处在于用 Gatan 特殊格式存储的图像只

能用 DM 软件打开。其他的标准商用软件(比如，Photoshop) 不能直接阅读 Gatan 特殊

存储格式。所以打不开用 Gatan 特殊格式存储的图像。 

Gatan 特殊存储格式究竟有什麽好处呢？首先这种特殊格式保留了所有同 Gatan CCD 
相机有关的参数。比如，图像的曝光时间，处理模式，电镜的放大倍数，样品名称，

以及操作者名字等等。此外，DM 软件许多特有功能的相关参数 (例如，图像在纸张上

的显示位置)也在 Gatan 特殊存储格式存储。 

如果用户需要使用其它的格式来存储图像时，比如，TIFF 或 JPEG,  需要特别加以注

意。下面是常会出现的错误。 

 使用早期的 GMS 软件版本（GMS1.2）时，使用”Save As… (TIFF)”。结果导致图

像分辨率的损失.  

为什麽使用”Save As… (TIFF)” 会损失图像分辨率呢? 

在使用这种存储格式时，DM 软件仅以屏幕显示器的分辨率对所显示的图像进行存储 
(TIFF)。一般屏幕显示器的分辨率设置在 1024 x 768 或 1280 x 1024。 这样如果图像的

分辨率(像素) 是 1024 x 1024，那麽就会出现分辨率损失。 

练习： 

在计算机桌面的文件夹(Gatan School)里，打开图像 “TiNbOx.dm3”。 

这张图像的分辨率(像素) 1024 x 1024 可以在图像状态” (Image Status)窗口中读出。 

在文件 (File)菜单下选择 Save As…。然后在存储格式的选择中选 TIFF 格式。键入文

件名字”TiNbOxSaveAsTiff” 并将该文件存入计算机桌面的文件夹 Gatan School 里。关

掉图像”TiNbOxSaveAsTiff”。 

重新打开图像”TiNbOxSaveAsTiff”，此时注意到图像的分辨率已经减为 512 x 512 或更

小。 

从这个练习可以清楚地看到，要想保留原始的图像分辨率，千万不能使用 “Save As… 
(TIFF)”。 

正确的方法是使用 “Export … (TIFF)”。 

使用这种方法(见下图)可以把原来的图像以标准的 8 位 TIFF 格式存储并保留原图像的

分辨率。 
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这个方法也适用于其他的存储格式。具体步骤是，在文件 (File)菜单下选择 Export 
Image。然后选择所需要的存储格式。 

 

 

重新打开图像 “TiNbOx.dm3”。练习上面介绍的图像 Export 方法并确认在转换图像存

储格式时，没有分辨率损失。 

 

值得指出的是，使用目前的 GMS 版本(1.4.0 以后)，应当使用下面的方法来存储图像

(TIFF, JPEG, BMP)。 

- 选择 File -> SaveDisplayAs…。 

- 选择图像存储格式。 

- 在对话栏中，选择（1）”Actual Resolution”;(2) SaveAsGreyScale.  
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如果选择“Screen Resolution”， 图像的分辨率与计算机显示频幕的分辨率相同。这样

就会造成图像分辨率的损失（如前节所述）。
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常用的键盘指令和操作小结 

 

* 打开图像显示对话窗口 

 同时按下键盘上的 “Ctrl” 和字母 D 键。 

* 拷贝(选择区域)到一个新的图像窗口 

 同时按下键盘上的 “Ctrl” 和字母 C 键。然后同时按下键盘上的 “Ctrl”，”Alt” 和字母 V 

键。 

* 在文件模式下移动图像 

 用鼠标点击图像(并保持按下状态)，移动鼠标。 

* 正方形区域选择 

 选用区域选择工具 (ROI 工具盘中的虚正方形)。点击图像中任何一点(作为区域选择的左上角)，按

下键盘上的"Shift” 键，同时按下并移动鼠标。 

* 2 的次方区域选择 

 选用区域选择工具 (ROI 工具盘中的虚正方形)。点击图像中任何一点(作为区域选择的左上角)，按

下键盘上的"Alt” 键，同时按下并移动鼠标。 

* 画 0，45，和 90 度直线 

 在画直线时，按下键盘上的"Shift” 键。 

* 画园形图案 

 在画椭圆时，按下键盘上的"Shift” 键。 

* 画正方形图案 

 在画矩形时，按下键盘上的"Shift” 键。 

* 画带箭头的直线 

 单向箭头: 在画直线时，按下键盘上的"Alt” 键。 

 双向箭头: 在画直线时，按下键盘上的"Ctrl” 键。 

* 改变线强度分布的积分宽度 

 用鼠标双击图像中的蓝白线。在对话窗口中，键入新的积分宽度值， 

* 强制图像关闭 (不存储数据变化) 

 在点击文件关闭图标(文件右上角的 X) 的同时，按下键盘上的"Alt” 键。 
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练习二 

图像处理与分析 
 

电子显微图像的处理和分析是电镜工作的一个重要组成部分。图像处理和分析的益处

如下。 

 改善图像质量 

 修正图像中的缺陷 

 从图像中获取某些特定的信息 

 图像的定量分析 

 图像的定量比较 

本节练习包括下面的练习内容。 

 图像的背底消除 

 刀痕消除 

 快速付里叶变换 (FFT) – 增强图像的周期信息 

 图像锐化 

DM 软件汇编语言 

DM 软件的功能之一是它有一套完整的自身汇编语言(Scripting)。DM 软件的汇编语言

看起来很像计算机程序设计中的 C 或 C++ 语言。 

DM 软件的汇编语言在实际工作中非常有用。通过以下的练习，你可以欣赏到它的功

用。 
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在这本练习册中，我们不对 DM 软件的汇编语言做详细介绍。我们的目的是使大家知

道怎样去运行一个已经写好的程序。 

下面是运行 DM 程序的具体步骤： 

（1）打开已经写好的程序； 

（2）同时按下键盘上的”Ctrl” 和 “Enter” 键。 

 

14． 图像的背底消除 

非均匀背底在电镜图像中是很常见的现象。造成这种情况的原因可来自电镜(非均匀照

明) 或者样品(厚度变化)。 

使用 DM 程序可以很容易地消除图像的非均匀背底。请做下面的练习。 

 

图像缩小法估计背底的非均匀度 

在计算机桌面的文件夹(Gatan School)里，打开图像 “carbon.dm3”。这幅图像的背底强

度由低 (左面) 变到高 (中心)。在图像的不同区域用鼠标来大概估计一下强度的差别 
(鼠标所在位置的强度值可以在”图像状态” (Image Status)窗口中读出。 

在计算机桌面的文件夹(Gatan School)里，打开程序文件夹(Script)。然后用鼠标(双击) 
打开程序 ”BKS.s”。 

程序运行: 用鼠标点击程序窗口”BKS.s”。同时按下键盘上的”Ctrl” 和 “Enter” 键。 

程序”BKS.s” 估计图像背底非均匀度的方法是将原始图像(下左图)逐步缩小 (每次缩小

2 倍)到 8 x 8 (即 x 和 y 方向各有 8 个像素)。虽然此时的图像(下中图)已经没有任何细

节可言，但它的强度变化正代表原始图像中的非均匀背底。下一步是将已经缩小的图

像再放大到原来的尺寸。这就是我们需要得到的非均匀背底。有了背底强度后，通过

简单的数学运算，就可以把背底从原始图像中减掉。然后显示背底修正后的图

像 ”carbon BKS” (下右图)。 
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 背底修正前 背底强度  背底修正后 

比较背底修正前后的图像。 

 

“3 点式” 图像背底消除 

在计算机桌面的文件夹(Gatan School)里，打开图像 “Al-bronze.dm3”。在这幅图像中，

样品厚度的变化引起大幅度的强度变化。 

在程序文件夹中，打开文件夹 ” 3-point logarithmic dodging”。打开程序”plane dodge 
setup.s”。这个程序的目的是为下面的背底消除程序做准备工作。 

在程序运行时，图像中会显示 3 个小方框。接下来需要在图像中确定这 3 个方框的位

置。其目的是希望背底消除后，这 3 处的强度大致相等。用鼠标把这些方框移动到已

选好 3 个不同位置上。 

下一步是打开程序”plane dodge.s”。同时按下键盘上的”Ctrl” 和 “Enter” 键来启动程

序。该程序利用 3 个局部的强度数值来模拟背底强度。当程序问到”是否产生新图像

时” (Create New Image?)，点击 OK。然后程序会显示背底修正后的图像。 

比较背底修正前后的图像。 

改变 3 个方框的位置，重复上面的步骤。比较结果。 

图像缩小法简单且容易使用，适用多种类型的图像。相比之下，“3 点式”方法虽然稍

复杂些，但具有灵活性。这种方法多适用于复杂一些的背底强度。另外，用户可以自

行选定图中的 3 个局部位置，从而得到不同的修正效果。 
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15． 快速付里叶变换 (FFT) – 增强图像的周期信息 

在图像处理中，快速付里叶变换 (FFT) 是最常使用的功能之一。和原始图像相比，付

式变换后的图像(简称付式变换) 含有同样的信息。唯一的区别在于付式变换将原始图

像中的信息(实空间) 在倒空间中显示。所以付式变换看起来与原始图像差别很大。但

是如果将付式变换(不做任何修改)再做一次付里叶变换 (称为反付式变换)，则变回到

原始图像。 

如果原始图像中有周期重复的细节(比如，晶体中的晶格条纹)，那麽在相应的付式变

换中就会有很强且有周期性的点子(衍射斑点)出现。这些衍射斑点和图像中的周期信

息一一对应。 

使用快速付里叶变换做图像处理的一般步骤是: (1) 将原图像做快速付里叶变换；(2)修
改付式变换图像(称为滤波)；(3) 做反付式变换。 

做快速付里叶变的前提条件是图像的尺寸必须是 2 的次方项，比如，256 x 256 或 512 
x 512，等等。在实际工作中，常用区域选择工具(ROI) 来把图像的尺寸限制在 2 的次

方项。 

在下面的练习中，我们将学习使用基于付式变换的滤波技术，来增强图像的周期信

息。 

 

环形滤波 

在计算机桌面的文件夹(Gatan School)里，打开图像 “Gold-1.dm3”。这是一张金颗粒高

分辨电子显微像。 

用区域选择工具(ROI 矩形图标)，在五次孪晶(五次对称) 上，做一个大小为 256 x 256 
的区域。然后在图像处理的菜单下 (Process) 选取 FFT。 如果需要，调整付式变换像的

亮度或衬度显示。注意在付式变换像中衍射斑点(呈五次对称) 分布在一个圆圈上。这

些衍射斑点来自于原始图像中金颗粒的晶格条纹。 

在过滤工具盘上(Masking) 点击环形滤波(Band filter) 图标(见下图)。然后点击付式变换

像。此时出现一个环形图案(暗白色)。用鼠标点击暗白色区域，使环形滤波器处于选

择状态 (园环的内外园分别被 4 个绿点包围)。然后用鼠标改变绿点的位置，使园环包

围衍射班点(即暗白色区域与斑点重叠)。 

Administrator
高亮

Administrator
高亮
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在 Process 菜单下，选择 Apply Mask。 

在出现的对话窗口中(下图)，选择 3 个像素作为平滑边缘(Smooth Edge By)并确认选

择”保留过滤区域” (Keep masked area)。然后点击 OK。 

   

 

在新的图像中，环形滤波区域外面的信息被过滤掉。 

在 Process 菜单下，选择反付里叶变换(IFFT) 把经过环形滤波后的付式变换像再变换

到实空间。将环形滤波处理后的图像与原始图像做比较。可以看出，处理后的图像保

留了所有的周期信息，此外原来图像的背底也已经被消除。 

 

孪生滤波(Twin mask filtering) 

孪生滤波的操作原理与上面的环形滤波类似。首先将原始图像做付里叶变换(FFT)，然

后对付式变换像做滤波(孪生滤波)。最后将滤波后的付式变换像做反付里叶变换

(IFFT)，从而得到处理图像。 

在计算机桌面的文件夹(Gatan School)里，打开图像 “noise.dm3”。 

在 Process 菜单下，选择付里叶变换(FFT)。在付式变换像中可以清楚看见两套有周期

性的亮点。这些亮点与原始图像中的周期噪音一一对应。 
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下面练习如何使用孪生滤波器来消除图像中的周期噪音。 

在滤波前，先用放大镜工具( ) 点击付式变换像的中心。这样可以看清

付氏变换像的细节，从而比较容易地调整孪生滤波区域的位置。如果需要，调整图像

窗口的大小。 

选择孪生滤波器图标，然后点击付式变换像。此时会出现一对暗白色的圆圈。圆圈的

大小表示滤波区域。用鼠标点击圆圈后，它的四周会出现 4 个绿点。当鼠标在绿点上

时，移动鼠标可以改变滤波区域的大小。当鼠标在滤波区域内时，移动鼠标则可以改

变滤波区域的位置。 

用鼠标点击其中一个圆圈的中心，然后将它移动到付式变换像中的任意一个亮点处。

注意当圆圈位置改变时，与其孪生的另外一个圆圈也同时朝相反的方向移动同样的距

离。当圆圈的位置调好后，再用鼠标选择孪生滤波器图标，并重复上面的过程对另一

套点子进行滤波。 

在 Process 菜单下，选择 Apply Mask。 

在出现的对话窗口中(下图)，选择 3 个像素作为平滑边缘(Smooth Edge By)并确认选

择”保留非过滤区域” (Keep unmasked area)。然后点击 OK。接下来选择反付里叶变换

(IFFT) 把经过滤波后的付式变换像再变换到实空间。 

将新的图像与原始图像做比较，可以看出原来的周期噪音大部分被滤掉了。剩余噪音

主要分布在图像的边缘。其原因是图像边缘的噪音在付式变换像中并不是严格地分布

在亮点上。而是分布在亮点附近垂直(或水平) 的方向上。因为我们仅仅滤掉付式变换

像中的亮点，在垂直(或水平) 方向上仍有残余的强度。从而在图像的边缘仍有剩余噪

音。 

 

 

 

16． 刀痕消除 

刀痕在生物样品电子显微像中比较常见。它是由于切片使用的刀片发钝引起。图像中

的刀痕大大地影响了图像的质量。然而使用 DM 程序，可以很容易去掉像刀痕这样的

假象。 

在计算机桌面的文件夹(Gatan School)里，打开图像 “Rohbild (knife marks).dm3”。 

在 Process 菜单下，选择付里叶变换(FFT)。在付式变换像中可以清楚看见一条强度微

弱的条纹 (下左图)。它就是原始图像中的刀痕在付式变换像中的现身。条纹的方向与
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刀痕的方向恰好垂直。所以，只要在付式变换像中消除这个条纹，我们就可以消除图

像中的刀痕。 

 

 

选择圆锥滤波器图标(扇形)，然后点击付式变换像。圆锥滤波器有两个基矢量(上左图

中箭头)。改变箭头的方向，即可以改变圆锥滤波器的角度。 

用鼠标点击选择图像中的箭头(端点呈绿色)。然后调整两个基矢量的方向使圆锥的滤

波区域恰好包住条纹(上右图)。 

在 Process 菜单下，选择 Apply Mask。选择 3 个像素作为平滑边缘(Smooth Edge By)并
确认选择”保留非过滤区域” (Keep unmasked area)。然后点击 OK。付式变换像中的条

纹已经被滤掉。选择反付里叶变换(IFFT) 把付式变换像再变换到实空间。可以看出，

原始图像中得刀痕已经消失。 
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17． 图像锐化 

图像锐化也是图像处理中常见的操作之一。图像锐化可使图像变得清晰。在 DM 软件

中，有多种图像锐化的方法。在下面的练习中，我们介绍一种简单且实用的图像锐化

方法。 

在计算机桌面的文件夹(Gatan School)里，打开图像 “Al-Cu-1.dm3”。 

具体步骤： 

- 在 Process 菜单下，选择 Special Filter (特殊过滤) -> Sharpen (锐化)。 

- 当锐化图像显示后，选择 Special Filter (特殊过滤) -> Smooth (平滑)。 

- 显示新的图像。此时可以关闭上面的锐化图像。 

比较锐化前后的图像。可以很清楚地看出，锐化提高了图像的分辨率。 

 


